Automatyczna aktualizacja firmware MikroTik i RouterOS

System scheduler do automatycznej aktualizacji firmware router’ów MikroTik i systemu RouterOS. Poniższy skrypt należy wkleić w terminal.

/system scheduler
add interval=1w name="Package upgrade" on-event=\
    "system package update install" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-date=sep/18/2018 start-time=07:13:19
add interval=1w name="Routerboard Upgrade" on-event=":global Var1\r\
    \n:global Var2\r\
    \n:set Var1 \"\$[/system package get system version]\"\r\
    \n:set Var2 \"\$[/system routerboard get current-firmware]\"\r\
    \n:if (\$Var1>\$Var2) do={/system routerboard upgrade;\r\
    \n/system reboot;\r\
    \n}" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-date=sep/18/2018 start-time=07:16:30

Źródło: http://tksja.com/automatically-upgrade-you-router-firmware-os/

Podziel się:

Dodaj komentarz

Ta strona używa Akismet do redukcji spamu. Dowiedz się więcej na temat przetwarzania komentarzy.