[How-To] Router MikroTik jako lokalny serwer DNS

W sieci LAN warto używać lokalnego serwera DNS, po pierwsze czas do zapytań serwera DNS spada, tak więc uzyskujemy lepszy Ping, a po drugie jesteśmy mniej narażeni na ataki DDoS.
Aby włączyć serwer DNS przechodzimy do zakładki IP -> DNS Poniżej przykład z podanymi 4 serwerami DNS do których będą forwardowane zapytania DNS gdy pierwszy raz połączymy się z jakąś stroną.

Podane cztery przykładowe adresy serwerów DNS należy zastąpić swoimi. Zalecam jako pierwszy adres podać swojego dostawcę internetu jako że ten będzie najbliższy, choć nie zawsze.

RouterOS local DNS Serwer

Następnie ustawiamy w DHCP server DNS – w tym wypadku jest to 192.168.1.1

ip dhcp-server network set dns-server=192.168.1.1 0

Na końcu cały ruch z zapytaniami w sieci kierujemy na nasz router MikroTik. Zmiana serwera na hoście też niczego nie zmieni gdyż router przejmie zapytania kierowane na port 53

/ip firewall nat
add action=redirect chain=dstnat comment="proxy dns" disabled=no dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat disabled=no dst-port=53 protocol=udp to-ports=53
/ip firewall filter add chain=input protocol=udp dst-port=53 in-interface=ether1 action=drop

Powyższy wpis do firewall’a blokuje dostęp do portu 53 (DNS) z zewnątrz, został dodany po komentarzu ze strony użytkownika SiB – celna uwaga.

 

Podziel się:

Dodaj komentarz

Ta strona używa Akismet do redukcji spamu. Dowiedz się więcej na temat przetwarzania komentarzy.