Podstawowe komendy w terminalu RouterOS – MikroTik

Podstawowe komendy routerów MikroTik z firmware RouterOS używając terminala. Komendy przydadzą się w codziennej pracy, dla przypomnienia lub nauki.

Wyświetlanie informacji

  • Informacje o portach USB i podłączonych urządzeniach
system resource usb
  • Informacje o CPU jak i IRQ oraz Dysku
system resource cpu
  • Wyświetlanie informacji o zasobach
system resource
  • Informacje o interfejsach
interface ethernet print
  • Tablica routingu
ip route print
  • Aktualna lista adresów IP
ip address print
  • Serwery DNS
ip dns print

Zmiana hasła administratora

user set admin password=nowehasło

Operacje na adresach IP

  • Dodanie adresu IP do port ethernet
ip address add interface=ether1 address=192.168.1.100 netmask=255.255.255.0 network=192.168.1.0 broadcast=192.168.255.255
  • Zmiana adresu portu ethernet (wpierw należy ustalić nr pozycji adresu komendą ip address print w naszym przypadku to 1)
ip address set 1 address=192.168.1.20/24
  • Usunięcie adresu z portu ethernet
ip address remove 1
  • Nazewnictwo portów ethernet
interface ethernet set 0 name=WAN
interface ethernet set 1 name=eth2
interface ethernet set 2 name=eth3
interface ethernet set 3 name=eth4
interface ethernet set 4 name=eth5
interface wireless set 0 name=wlan1
  • Zmiana adresu MAC portu ethernet1
interface ethernet set ether1 mac-address=xx.xx.xx.xx.xx
  • Wyłączenie i włączenie portu ethernet1
interface disable ether1
interface enable ether1
  • Zmiana nazwy Routera
system identity set name=Router

Konfiguracja mostu (Bridge)

  • Tworzenie mostu
interface bridge add auto-mac=no l2mtu=1594 name=bridge-local protocol-mode=rstp
  • Dodawanie portów ethernet do mostu
interface bridge port add bridge=bridge-local interface=wlan1
interface bridge port add bridge=bridge-local interface=eth3
interface bridge port add bridge=bridge-local interface=eth4

DHCP Serwer

  • Tworzenie puli adresów dla DHCP
ip pool add name=default-dhcp ranges=192.168.2.2-192.168.2.254
  • Konfiguracja Serwera DHCP
ip dhcp-server add address-pool=default-dhcp disabled=no interface=bridge-local name=default
ip dhcp-server network add address=192.168.2.0/24 comment=”” dns-server=192.168.2.1 gateway=192.168.2.1
  • Uruchomienie klienta DHCP na porcie WAN
ip dhcp-client add comment=”” disabled=no interface=WAN

VLAN

  • Dodanie VLAN na odpowiednim porcie ethernet (eth2 w tym przypadku id 10 i 20)
interface vlan add interface=eth2 l2mtu=1594 name=”VLAN 10″ vlan-id=10
interface vlan add interface=eth2 l2mtu=1594 name=”VLAN 20″ vlan-id=20
  • Przypisanie VLAN 10 do mostka
interface bridge port add bridge=bridge-local interface=”VLAN 10″
  • Przypisanie adresu VLAN 20
ip address  add address=192.168.1.100/24 interface=”VLAN 20″

Eksport konfiguracji

  • Eksport ustawień
/export
  • Eksport ustawień do pliku
/export compact file=nazwapliku
  • Eksport ustawień firewalla do pliku
/ip firewall export file=nazwapliku
  • Eksport ustawień mangle firewalla do pliku
/ip firewall mangle export file=nazwapliku
  • Eksport ustawień Queue do pliku
/queue export file=nazwapliku
  • Eksport ustawień Simple Queue do pliku
/queue simple export file=nazwapliku

 

Podziel się:

Dodaj komentarz

Ta strona używa Akismet do redukcji spamu. Dowiedz się więcej na temat przetwarzania komentarzy.